HELP Forum Car won't start, Spark Plug Melted? Car throwing sparks down as you drive down the road? Ask your car questions here.

HELP ME PLEASE CLUTCH/GEAR ISSUE :( - newbie

Old 09-10-2015, 10:38 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Sep 2015
Location: London On
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Vehicle: 2003 Hyundai Tiburon 2.7 GT v6
Default HELP ME PLEASE CLUTCH/GEAR ISSUE :( - newbie

Hey guys new to Tiburons as well as this forum hopefully someone can help me out! I bought an 03 2.7, guy told me clutch had just been replaced put dealer plates on it that night drove it about 5 km home on the way home clutch was slipping , got home put car in neutral, put in first releasing clutch and nothing the car could go in ANY GEAR and WONT STALL, doesn't even need the clutch to enter the gear and all I could smell was a lotta clutch, Shut it off for the night, boosted it in the morning as the battery is garbage as well, put it in first and the car moves, as quick as I can I get to my buddys dad shop but on the way there same thing !! the car was loosing power all the way till I got to the shop.. any ideas what it might be this shop is quite busy and dont want to have it sitting there.. Ive read about same problem but not one that started moving again the next day which was today Please let me know if you had problem or know anything much appreciated
Londontiburon is offline  
Old 09-10-2015, 11:43 AM
  #2  
Moderator
 
JonGTR's Avatar
 
Join Date: May 2001
Location: San Antonio, TEXAS!!!
Posts: 7,155
Received 6 Likes on 5 Posts
Vehicle: 01 Tiburon Turbo, 99 Tiburon F2E, 2013 Avalon XLE Touring
Default

Try bleeding the slave cylinder. It might be keeping the clutch in the open position.
JonGTR is offline  
Old 09-10-2015, 05:48 PM
  #3  
Junior Member
Thread Starter
 
Join Date: Sep 2015
Location: London On
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Vehicle: 2003 Hyundai Tiburon 2.7 GT v6
Default

Getting it check out tn, any other ideas could it just be adjusting ? or is my clutch gone
Londontiburon is offline  
Old 09-11-2015, 08:05 AM
  #4  
Moderator
 
JonGTR's Avatar
 
Join Date: May 2001
Location: San Antonio, TEXAS!!!
Posts: 7,155
Received 6 Likes on 5 Posts
Vehicle: 01 Tiburon Turbo, 99 Tiburon F2E, 2013 Avalon XLE Touring
Default

If it had just been replaced, then it was an install error of some sort. If they lied to you, then I would bet the clutch is fried. The 2.7L is notorious for bad factory clutches.
JonGTR is offline  

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: