The Car is "Hiccupping" - Hyundai Aftermarket

HELP Forum Car won't start, Spark Plug Melted? Car throwing sparks down as you drive down the road? Ask your car questions here.

The Car is "Hiccupping"

Reply

 
 
 
Old 11-13-2009, 08:34 PM
  #1  
Moderator
Thread Starter
 
Join Date: Mar 2009
Location: Colchester, VT
Posts: 1,442
Thanks: 0
Thanked 0 Times in 0 Posts
Vehicle: 2013 Subaru Legacy 2.5l Limited
Default The Car is "Hiccupping"

Sooo recently, my car has been doing something a little strange. Last week I noticed it big time when I almost got hit because of it. I went to pull out quickly, the car went a little then did a quick hesitation, then kicked in as if I had pushed on the gas harder. I noticed it before but it was when I would be accelerating when I was already going 30 mph. I asked Keyan about it and he suggested that it has to do something with the air flow sensor malfunctioning. Some more background, at 32,500 miles the warranty states to replace the air fuel filter. apparently this is new part in the HDs. I asked the guy at the dealership about it, when i got my 30,000 mile service done, and he said not to worry about unless you have a problem. the manual says to replace the fuel filter at 52,000 miles.

Current mileage: 41,200 miles

any suggestions?
iheartmyredcar is offline  
Reply With Quote
Old 11-13-2009, 08:44 PM
  #2  
Senior Member
 
tibbykid91's Avatar
 
Join Date: Oct 2008
Location: North Carolina
Posts: 562
Thanks: 0
Thanked 0 Times in 0 Posts
Vehicle: 2008 Tiburon
Default

Sounds like a vac leak.
tibbykid91 is offline  
Reply With Quote
Old 11-13-2009, 08:47 PM
  #3  
Senior Member
 
Fintile's Avatar
 
Join Date: Apr 2008
Location: San Diego, Ca
Posts: 780
Thanks: 0
Thanked 0 Times in 0 Posts
Vehicle: 2004 Hyundai Accent 1.6T
Default

could be the injectors are dirty...also too check the wiring around all the injectors and the map sensors
Fintile is offline  
Reply With Quote
Old 11-13-2009, 08:50 PM
  #4  
Administrator
 
187sks's Avatar
 
Join Date: Mar 2006
Location: Lacey, WA
Posts: 12,507
Thanks: 0
Thanked 0 Times in 0 Posts
Vehicle: Two Accents, Mini, Miata, van, and a ZX-6
Default

Hook it to an OBDII scanner that does realtime data and see if there are flat spots in the TPS or the MAF.
187sks is offline  
Reply With Quote
Old 11-13-2009, 08:51 PM
  #5  
Moderator
Thread Starter
 
Join Date: Mar 2009
Location: Colchester, VT
Posts: 1,442
Thanks: 0
Thanked 0 Times in 0 Posts
Vehicle: 2013 Subaru Legacy 2.5l Limited
Default

QUOTE (tibbykid91 @ Nov 13 2009, 10:44 PM) <{POST_SNAPBACK}>
Sounds like a vac leak.



QUOTE (Fintile @ Nov 13 2009, 10:47 PM) <{POST_SNAPBACK}>
could be the injectors are dirty...also too check the wiring around all the injectors and the map sensors


sooo run a fuel injector cleaner thought it and see if that helps or take it to the dealer? because we know murphys law, it wont do it at the dealership

ok......i know the basics about cars and im learning as i go......so a little guidance on the location of the wiring around the injectors would be great thanks
iheartmyredcar is offline  
Reply With Quote
Old 11-13-2009, 08:55 PM
  #6  
Administrator
 
187sks's Avatar
 
Join Date: Mar 2006
Location: Lacey, WA
Posts: 12,507
Thanks: 0
Thanked 0 Times in 0 Posts
Vehicle: Two Accents, Mini, Miata, van, and a ZX-6
Default

Post an engine bay pic and I'll circle them.

But buy a scanner and it'll make your life way easier.
187sks is offline  
Reply With Quote
Old 11-13-2009, 08:57 PM
  #7  
Moderator
Thread Starter
 
Join Date: Mar 2009
Location: Colchester, VT
Posts: 1,442
Thanks: 0
Thanked 0 Times in 0 Posts
Vehicle: 2013 Subaru Legacy 2.5l Limited
Default

QUOTE (187sks @ Nov 13 2009, 10:55 PM) <{POST_SNAPBACK}>
Post an engine bay pic and I'll circle them.

But buy a scanner and it'll make your life way easier.


how much ruffly?



that good or you need a better one?
iheartmyredcar is offline  
Reply With Quote
Old 11-13-2009, 08:59 PM
  #8  
Administrator
 
187sks's Avatar
 
Join Date: Mar 2006
Location: Lacey, WA
Posts: 12,507
Thanks: 0
Thanked 0 Times in 0 Posts
Vehicle: Two Accents, Mini, Miata, van, and a ZX-6
Default

$50-$200

As long as it displays live data it'll be fine. Mine was mid-range so it doesn't do pre-96 cars but that's it's only limitation.
187sks is offline  
Reply With Quote
Old 11-13-2009, 09:05 PM
  #9  
Moderator
Thread Starter
 
Join Date: Mar 2009
Location: Colchester, VT
Posts: 1,442
Thanks: 0
Thanked 0 Times in 0 Posts
Vehicle: 2013 Subaru Legacy 2.5l Limited
Default

posted a pic for you
iheartmyredcar is offline  
Reply With Quote
Old 11-13-2009, 09:17 PM
  #10  
Administrator
 
187sks's Avatar
 
Join Date: Mar 2006
Location: Lacey, WA
Posts: 12,507
Thanks: 0
Thanked 0 Times in 0 Posts
Vehicle: Two Accents, Mini, Miata, van, and a ZX-6
Default

remove the spark plug cover and check that the wires are on tight. Check the coil side of the plug wires. Check the plugs going into both coils. Check the TPS plug on the throttle body, check the MAF plug.
Attached Images
File Type: jpg
1011091817.jpg (82.0 KB, 1 views)
187sks is offline  
Reply With Quote

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: